* [ needs netscape 3 or higher ]